Tag : raspberry-pi

I set up the Nginx Reverse Proxy Manager by Jamie Curnow on my Raspberry Pi using docker and docker-compose. This is the yml stack file: — version: ‘3’ services: app: image: ‘jc21/nginx-proxy-manager:latest’ ports: – ’80:80′ #HTTP Traffic – ’81:81′ #Dashboard Port – ‘443:443’ #HTTPS Traffic volumes: – ./config.json:/app/config/production.json – ./data:/data – ./letsencrypt:/etc/letsencrypt db: image: ‘jc21/mariadb-aria:10.4’ ..

Read more

Currently I am trying to install scikit-learn in a Docker container on a Raspberry Pi 2. In the Dockerfile I have written: RUN pip install scikit-learn For a few hours now I have the following messages: Installing build dependencies: still running… Installing build dependencies: still running… … Installing build dependencies: still running… Installing build dependencies: ..

Read more

I want to run a nginx ingress controller on a raspberry kubernetes. Unfortunately I get the error message Events: Type Reason Age From Message —- —— —- —- ——- Normal Scheduled 14m default-scheduler Successfully assigned ingress-nginx/ingress-nginx-controller-75557995f8-dz7hz to node1-pi4 Warning FailedMount 12m kubelet Unable to attach or mount volumes: unmounted volumes=[webhook-cert], unattached volumes=[kube-api-access-7k4qh webhook-cert]: timed out ..

Read more

I’m trying to set up a simple database system using a PostgreSQL Docker container and an Adminer container as a backend. Note this is all running on a RaspberryPi 4. docker-compose.yml: services: postgres: image: postgres restart: on-failure ports: – 5432:5432 env_file: – ./.auth_file volumes: – db:/var/lib/postgresql/data adminer: image: adminer restart: on-failure ports: – 8070:8080 env_file: ..

Read more

I am trying to build a Python IoTEdge module for a Raspberry Pi 4 (uses Docker to build image). I set the target architecture for my IoTEdge solution as arm32v7 I don’t believe anything is wrong with my requirements.txt, but just for reference: requirements.txt azure-iot-device~=2.0.0 opencv-python numpy requests Dockerfile FROM arm32v7/python:3.7-slim-buster # RUN [ "cross-build-start" ..

Read more

I have a PostgreSQL database for some sensoric data on my Raspberry Pi. It runs on the postgres:12-alpine tag without automatic updates yet. Before the update, I got the following version string: (‘PostgreSQL 12.3 on arm-unknown-linux-musleabihf, compiled by gcc (Alpine 9.3.0) 9.3.0, 32-bit’,) After I noticed that it was a bit out of date, I ..

Read more