Category : yum

I have a Docker container based on the latest amazonlinux image running on my work computer and I get this error when I attempt to run yum "anything" (e.g. yum update, yum install ____): failure: repodata/repomd.xml from amzn2-core: [Errno 256] No more mirrors to try. https://cdn.amazonlinux.com/2/core/2.0/x86_64/f915d0987d73328ab3992d03ddbce189bca8804de19d89f09b847dfcaa6bc1af/repodata/repomd.xml?instance_id=URLError&region=unknown: [Errno 14] curl#60 – "SSL certificate problem: unable to ..

Read more

we are trying to install docker on our Centos 7.5 according to https://phoenixnap.com/kb/how-to-install-docker-centos-7 and some other similar guides and failing with following error, can someone advise how to overcome it or provide alternative installation steps from his experience? [[email protected]******1 ~]# yum install -y docker-ce Loaded plugins: fastestmirror Loading mirror speeds from cached hostfile centos-sclo-rh: centos.spd.co.il ..

Read more

I want install the lastest verion of docker following with this doc. But when i ran sudo yum install docker-ce docker-ce-cli containerd.io. I got the following error: … –> Finished Dependency Resolution Error: Package: containerd.io-1.4.4-3.1.el7.x86_64 (docker-ce-nightly) Requires: container-selinux >= 2:2.74 Available: 2:container-selinux-1.10.3-59.el7.centos.x86_64 (extras) container-selinux = 2:1.10.3-59.el7.centos Available: 2:container-selinux-1.12.5-14.el7.centos.x86_64 (extras) container-selinux = 2:1.12.5-14.el7.centos Available: 2:container-selinux-2.9-4.el7.noarch (extras) ..

Read more

[[email protected] yum.repos.d]# yum install docker-ce-20.10.2* Loaded plugins: fastestmirror Loading mirror speeds from cached hostfile * base: la.mirrors.clouvider.net * extras: mirrors.ocf.berkeley.edu * updates: sjc.edge.kernel.org Resolving Dependencies –> Running transaction check —> Package docker-ce.x86_64 3:20.10.2-3.el7 will be installed –> Processing Dependency: container-selinux >= 2:2.74 for package: 3:docker-ce-20.10.2-3.el7.x86_64 –> Processing Dependency: containerd.io >= 1.4.1 for package: 3:docker-ce-20.10.2-3.el7.x86_64 –> ..

Read more

I build a Dockerimage with additional repos. This is the code to the part where it fails: FROM registry.access.redhat.com/redhat-openjdk-18/openjdk18-openshift USER root ADD content / RUN cp /opt/yum/HDP.repo /etc/yum.repos.d/HDP.repo RUN yum -y update && yum -y –enablerepo rhel-7-server-optional-rpms install bzip2 python36-pip python36 python36-devel openssl krb5-workstation mysql-devel gcc hadoop-client hadoop-libhdfs libtirpc-devel telnet && yum clean all -y ..

Read more