Category : wso2-am

I am installing API Manager on My GCP Cluster using helm chart (https://artifacthub.io/packages/helm/wso2/am-single-node) using git clone methods after changing the three files(wso2am-gateway-ingress.yaml, wso2am-ingress.yaml and wso2am-websub-ingress.yam ) following Kubernetes website info tips on https://kubernetes.io/docs/concepts/services-networking/ingress/ apiVersion: networking.k8s.io/v1 kind: Ingress metadata: name: ingress-resource-backend spec: defaultBackend: resource: apiGroup: k8s.example.com kind: StorageBucket name: static-assets rules: – http: paths: – path: ..

Read more

I am currently using WSO2 with Docker. I have published some APIs on the store but if Docker reboots all loose all my APIs. Therefore, I have followed this tutorial https://apim.docs.wso2.com/en/latest/install-and-setup/setup/reference/common-runtime-and-configuration-artifacts/#common-runtime-and-configuration-artifacts to create a folder that I mount into the wso2-artifact-volume. But when launching the Publisher it says that no APIs found. If I look ..

Read more

I am currrently using 4 WSO2 modules inside my docker-compose file as shown below: mysql: image: mysql:5.7.31 container_name: mysql ports: – 3306 environment: MYSQL_ROOT_PASSWORD: root volumes: – ./conf/mysql/scripts:/docker-entrypoint-initdb.d – ./conf/mysql/conf/my.cnf:/etc/mysql/my.cnf ulimits: nofile: soft: 20000 hard: 40000 command: –ssl=0 –max_connections=10000 healthcheck: test: ["CMD", "mysqladmin" ,"ping", "-uroot", "-proot"] interval: 30s timeout: 60s retries: 5 start_period: 80s am-analytics-worker: ..

Read more

I can’t login to WSO2 API Manager after installation. I perform the installation as indicated in these steps: https://wso2.com/api-management/install/docker-compose/get-started/ API Manager for Docker Compose. According to the instructions: Running the product: Once WSO2 API Manager is successfully deployed, access the following URLs on your favorite web browser using the credentials username: admin and password: admin. ..

Read more

I am trying to configure Traefik and WSO2 API Manager. Basically, I want to configure Traefik to handle https. labels: – "traefik.enable=true" – "traefik.http.middlewares.service-am-https.redirectscheme.scheme=https" – "traefik.http.routers.service-am-http.entrypoints=web" – "traefik.http.routers.service-am-http.rule=Host(`xx.xx.xx`) && Path(`/apim/admin`)" – "tr[email protected]docker" – "traefik.http.routers.service-am.tls=true" – "traefik.http.routers.service-am.rule=Host(`xx.xx.xx`) && Path(`/apim/admin`)" – "traefik.http.routers.service-am.entrypoints=web-secure" – "traefik.http.services.service-am.loadbalancer.server.port=9443" I also included this in the deployment.toml file for API Manager. [catalina.valves.valve.properties] className ..

Read more

I’m running 3 images for API-M and API-M Analytics in Docker: wso2am:3.0.0-centos7 is image for API-M (link) wso2am-analytics-worker:3.0.0-centos7 is image for API-M Analytics Worker (link) wso2am-analytics-dashboard:3.0.0-centos7 is image for API-M Analytics Dashboard (link) The problem is I dont know how to configure containers which run these images. wso2am:3.0.0-centos7 -> container named am ( IP:172.17.0.3) ports: ..

Read more