Category : spacy

I am following the instruction (https://github.com/huggingface/transfer-learning-conv-ai) to install conv-ai from huggingface, but I got stuck on the docker build step: docker build -t convai . I am using Mac 10.15, python 3.8, increased Docker memory to 4G. I have tried the following ways to solve the issue: add RUN pip3 install –upgrade setuptools in Dockerfile ..

Read more

I already have a docker image built with spacy and other dependencies installed. I am trying to build another image using docker build, pulling from the existing image, which will contain non-english spacy modules. I am using Docker desktop to do this. This is my docker file: FROM docker/image:14jul2020 ENV http_proxy="http://internet.com:83" ENV https_proxy="http://internet.com:83" # spacy ..

Read more

I’m trying to build HMNET docker image but keep running into this issue. I don’t have a lot of experience with Python/Docker and could really use some help….. => ERROR [19/22] RUN python -m spacy download en 2.7s —— > [19/22] RUN python -m spacy download en: #22 2.335 Traceback (most recent call last): #22 ..

Read more

When I’m trying to deploy my docker file with the ‘RUN python -m spacy download en_core_web_lg’ command, the docker is crashing in the Azure cloud but working fine in the local docker build. Can anyone shred a light on this? Docker file: FROM python:3.7-slim-buster RUN apt-get update && apt-get install -y libgtk2.0-dev cmake libpoppler-cpp-dev poppler-utils ..

Read more