Category : sharp

Installing sharp on M1 Mac with yarn install is OK, but with Docker results in the following error: error /usr/src/app/node_modules/sharp: Command failed. Exit code: 1 Command: (node install/libvips && node install/dll-copy && prebuild-install) || (node install/can-compile && node-gyp rebuild && node install/dll-copy) Arguments: Directory: /usr/src/app/node_modules/sharp Output: sharp: Installation error: Use with glibc 2.24 requires manual ..

Read more

During Docker build in Gitlab job pipeline the process is freezed on [email protected] install /app/node_modules/sharp (node install/libvips && node install/dll-copy && prebuild-install) || (node install/can-compile && node-gyp rebuild && node install/dll-copy) sharp: Downloading https://github.com/lovell/sharp-libvips/releases/download/v8.10.6/libvips-8.10.6-linux-x64.tar.br After 1 hour buil is killed by timeout. Dockerfile: FROM node:14.17.0 WORKDIR /app ARG NODE_ENV=dev ENV NODE_ENV $NODE_ENV ENV PORT 3005 ..

Read more

When running an npm install locally everything is fine but as soon as I try it inside my docker container I get the following error: /api/node_modules/sharp/lib/constructor.js:1 Something went wrong installing the "sharp" module Error relocating /api/node_modules/sharp/build/Release/../../vendor/8.10.6/lib/libvips-cpp.so.42: _ZNSt7__cxx1119basic_ostringstreamIcSt11char_traitsIcESaIcEEC1Ev: symbol not found Any help greatly appreciated! Docker image is incredibly simple: FROM node:12.13.0-alpine AS alpine WORKDIR /api ..

Read more

I am trying to run a container based on my app image by using docker and i getting the next error: /app/node_modules/sharp/lib/libvips.js:68 throw new Error(‘${vendorPlatformId}’ binaries cannot be used on the ‘${currentPlatformId}’ platform. Please remove the ‘node_modules/sharp’ directory and run ‘npm install’ on the ‘${currentPlatformId}’ platform.); Error: ‘darwin-x64’ binaries cannot be used on the ‘linux-x64’ ..

Read more

I am trying to use sharp (node image processing library) with docker and webpack. Everything works fine with my local environment on my own machine but when I am using docker things are not working and I get an error Can’t find module sharp In webpack configuration, I marked sharp as external dependency externals: { ..

Read more