Category : pip

We have a strange bug in our project, on our server a newly added package can’t be installed with the following error message: ERROR: Could not find a version that satisfies the requirement minify-html==0.6.8 (from versions: none) ERROR: No matching distribution found for minify-html==0.6.8 This is in a docker container and doesn’t make any sense, ..

Read more

I’m building a Docker image with a requirements.txt file. Every time I build the image it keeps failing due to some package version not being present. For example ARG BASE_CONTAINER=tensorflow/tensorflow FROM $BASE_CONTAINER # 2) change to root to install packages USER root COPY requirements.txt requirements.txt # 3) install packages RUN pip install -r requirements.txt ERROR: ..

Read more

I am trying to install molecule into my docker image’s python, so that I can run molecule test. I am using a Dockerfile to build the Docker image. Running: RUN pip install molecule Yields: Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-build-xgVCo_/molecule/ According to https://github.com/facebook/prophet/issues/418 I should run pip install –upgrade setuptools ..

Read more

When installing Python package through pip in a Dockerfile, such as: pip install –trusted-host pypi.python.org -r requirements.txt with requirements.txt, e.g. as: python-dotenv>=0.15.0 psycopg2>=2.8.6 sqlalchemy>=1.3.22 numpy>=1.19.0 rasterio>=1.1.8 pandas>=1.1.5 geopandas>=0.8.1 matplotlib>=3.3.0 seaborn>=0.11.0 I recently seen this warning: WARNING: Running pip as the ‘root’ user can result in broken permissions and conflicting behavior with the system package manager. ..

Read more

I have a pretty weird case – even don’t know where to look. I have a Python package e.g. my_utils which is uploaded to artifactory (same as PyPi). Project structure: my_utils __init__.py first_package __init__.py some_file.py first_package/some_file.py def do_job(): print("job_done") my_utils/init.py from first_package.some_file import do_job So when I do pip install my_utils – I can do ..

Read more

I try to install docker-compose into docker-container but it fails to build. Here’s my dockerfile: FROM jenkinsci/blueocean USER root RUN apk add –no-cache py-pip python3-dev libffi-dev openssl-dev gcc libc-dev rust cargo make gettext RUN pip3 install docker-compose USER jenkins And it shows me an error: Building wheels for collected packages: bcrypt, cryptography, pynacl, pyrsistent, PyYAML ..

Read more

Hello friends this is my first question in this website have this problème when i execute this script "https://github.com/andrey-yantsen/tlscontact-appointment-finder" WARNING: Running pip as the ‘root’ user can result in broken permissions and conflicting behaviour with the system package manager. It is recommended to use a virtual environment instead: https://pip.pypa.io/warnings/venv Creating a virtualenv for this project… ..

Read more