Category : node-modules

I’m running the command docker run globoapp/latest and it’s showing me > [email protected] start > react-scripts start node:internal/modules/cjs/loader:488 throw e; ^ Error [ERR_PACKAGE_PATH_NOT_EXPORTED]: Package subpath ‘./lib/tokenize’ is not defined by "exports" in /app/node_modules/postcss-safe-parser/node_modules/postcss/package.json at new NodeError (node:internal/errors:371:5) at throwExportsNotFound (node:internal/modules/esm/resolve:429:9) at packageExportsResolve (node:internal/modules/esm/resolve:683:3) at resolveExports (node:internal/modules/cjs/loader:482:36) at Function.Module._findPath (node:internal/modules/cjs/loader:522:31) at Function.Module._resolveFilename (node:internal/modules/cjs/loader:919:27) at Function.Module._load (node:internal/modules/cjs/loader:778:27) ..

Read more

I tried ti dockerize my node app, but it won’t work because of this puppeteer error, can you help me fixing this error? The Troubleshooting Site doesn’t. Thanks, regards Steep Below is the error node app.js /usr/src/node_modules/puppeteer/lib/cjs/puppeteer/node/BrowserRunner.js:197 reject(new Error([ ^ Error: Failed to launch the browser process! spawn /usr/src/node_modules/puppeteer/.local-chromium/linux-901912/chrome-linux/chrome ENOENT TROUBLESHOOTING: https://github.com/puppeteer/puppeteer/blob/main/docs/troubleshooting.md at onClose (/usr/src/node_modules/puppeteer/lib/cjs/puppeteer/node/BrowserRunner.js:197:20) ..

Read more

I have set up a GraphQL server and tried to deploy it on EC2 using docker-compose. There is an error that "nodemon not found in npm". After adding "–global nodemon" in the Docker file, I ran docker-compose down, docker container prune, docker image rm [image name], then docker-compose up –build. Then there is this Error: ..

Read more

I am getting this when I am trying to push my code into github actions or building dockerimage. shell: /usr/bin/bash -e {0} npm WARN read-shrinkwrap This version of npm is compatible with [email protected], but package-lock.json was generated for [email protected] I’ll try to do my best with it! I tried to implement this Link it works ..

Read more

Browserslist: caniuse-lite is outdated. Please run: npx [email protected] –update-db2 After I deployed my Google App Engine app using Google Cloud Build, I got the above error. So I ran the command and got this message. npx: installed 6 in 2.26s Latest version: 1.0.30001237 Installed version: 1.0.30001237 caniuse-lite is up to date And I still get ..

Read more

I have an NPM monorepo project which, where I want to execute a script under one of the packages. This is the project structure: packageA packageB packageC package.json Each package contains its own package.json. The project is built using lerna. In packageA I have the following package.json: { "name": "packageA", "version": "1.0.0", "description": "", "main": ..

Read more

This is my project structure: project/ node_modules/ src/ .gcloudignore cloudbuild.yaml Dockerfile package.json Here is how I’m building it: gcloud builds submit ./project –config=./project/cloudbuild.yaml –project=$PROJECT_ID // AND SOME SUBSTITUTIONS This is my cloudbuild.yaml file: steps: # BUILD IMAGE – name: "gcr.io/cloud-builders/docker" args: – "build" – "–tag" – "gcr.io/$PROJECT_ID/$_SERVICE_NAME:$_TAG_NAME" – "." timeout: 180s # PUSH IMAGE TO ..

Read more