Category : iis

My dotnet core API connection strings ("Data Source=SERVER;Initial Catalog=DB;Trusted_Connection=True;") use the IIS Application Pools Identity for authorization with the MSSQL servers. I’m about to move the hosting of the API from IIS to a docker container on another server, but cannot for the life of me figure out, how to provide the app/container with the ..

Read more

I have a custom CGI which handles HTTP requests located under D:/Root/ And consists of AppCGI.dll and AppCGI.exe So if I run the app I’d use this URL: http://localhost/WebRoot/AppCGI.cgi?Mod=MyWebApplet Official Microsoft Docker image looks like this: FROM mcr.microsoft.com/windows/servercore/iis RUN powershell -NoProfile -Command Remove-Item -Recurse C:inetpubwwwroot* WORKDIR /inetpub/wwwroot COPY content/ . How can I specify that ..

Read more

I have IIS app with Dot.Net core 2.1, I deploy to docker , it is not working. Please tell me what is my missing in Docker file. Please see my code below and app in IIS Dockerfile FROM mcr.microsoft.com/dotnet/aspnet:2.1 AS base WORKDIR /app EXPOSE 80 FROM mcr.microsoft.com/windows/servercore/iis RUN powershell -NoProfile -Command Remove-Item -Recurse C:inetpubwwwroot* WORKDIR ..

Read more

When copying the application content into the container, it works. But if rather than copying, the folder is mapped to the folder in the host, I get 401 from IIS. So, this works # Dockerfile FROM microsoft/aspnet COPY ./src/publish/ /inetpub/wwwroot # ——————————— # docker-compose.yaml version: ‘3.8’ services: webapp: build: . ports: – "8080:80" Browse to ..

Read more

I am new in .NET Core and as far as I see from my search on the web, appsettings.Development.json is used for development config while developing the app and appsettings.Production.json is used on the published app in production server. Here are the example part that I set on both: appsettings.Development.json: "ConnectionStrings": { "DefaultConnection": "Server=localhost,21433;Initial Catalog=DemoDbDev;User ..

Read more

I have the following working with microsoft/iis, but I would like to get it working with the smaller nanoserver. When I replace microsoft/iis with nanoserver/iis this line fails. Is it because exe files cannot run in nanoserver? C:vc_redist-x64.exe /quiet /install FROM nanoserver/iis This works: FROM microsoft/iis ADD PHP_7.3.26-NTS.zip C:php.zip #unzip RUN powershell -Command "expand-archive -Path ..

Read more