Category : asp.net-core-3.1

In windows container, how to graceful shutdown asp.net core application? I want use external process(ex: bash,powershell,dotnet core console application) to update my external module dll(be using by Assembly.Load). So I need to stop my application to avoid dll file be lock. I wish stop by graceful shutdown. My production environment has windows and Linux versions. ..

Read more

I’m using the template from microsoft’s docs for creating a docker container which should run my simple spa https://docs.microsoft.com/en-us/visualstudio/containers/container-tools-react?view=vs-2019 This is the file #See https://aka.ms/containerfastmode to understand how Visual Studio uses this Dockerfile to build your images for faster debugging. FROM mcr.microsoft.com/dotnet/core/aspnet:3.1-buster-slim AS base WORKDIR /app EXPOSE 80 RUN curl -sL https://deb.nodesource.com/setup_10.x | bash – ..

Read more

Container is working all the time: When I run an app in Visual Studio debugger: I can access my page normally on url https://localhost:49170/ – everything works fine. However if I close debug and try to access it ( containter is running all the time ), page is not available. I tried to search for ..

Read more

I am trying to use System.Drawing in my .NET Core application. I had it working in 2.2 but after upgrading to 3.1, I am getting the error "Unable to find an entry point named ‘GdipCreateFromXDrawable_linux’ in shared library ‘libgdiplus’" when running in my Docker container. I was getting the error "Could not open display (X-Server ..

Read more

I’m building an ASP.NET Core 3.1 application which uses IBM.Data.DB2.Core-lnx to access the DB of a legacy application. It works when using the normal Debian images. But I’d like to use Alpine instead for smaller images. I had some errors about missing files: Error loading shared library libpam.so.0: No such file or directory (needed by ..

Read more

I’m trying to test the release version of my application inside a docker container on my local machine, and I keep getting the warning below when I spin up the container, and it refuses the requests: Unable to bind to http://localhost:5000 on the IPv6 loopback interface: ‘Cannot assign requested address’. I’ve checked this post, and ..

Read more