Category : apt-get

I’m trying to run these two lines from my docker file using "docker build . ": FROM ubuntu:latest RUN apt-get update This is what happens when I run it (containing the errors): [+] Building 16.0s (6/18) => [internal] load build definition from Dockerfile 0.0s => => transferring dockerfile: 923B 0.0s => [internal] load .dockerignore 0.0s ..

Read more

When I try to build a simple docker image: in Dockerfile: FROM ubuntu:18.04 RUN apt-get update The output is: $ sudo docker build –no-cache -t testbuild . Sending build context to Docker daemon 3.471MB Step 1/2 : FROM ubuntu:18.04 —> c090eaba6b94 Step 2/2 : RUN apt-get update —> Running in 53d64603442f Ign:1 http://archive.ubuntu.com/ubuntu bionic InRelease ..

Read more

I am trying to create a docker image which includes an installed Firefox browser, using openjdk:11-slim or openjdk:11 as my base image. This is a minimal reproducible example of my dockerfile: FROM openjdk:11 RUN rm -rf /var/lib/apt/lists/* && apt-get update && apt-get install -y –no-install-recommends firefox Here is the output of running docker build .: ..

Read more

Running docker build with below mentioned docker file on jenkins master (linux) is giving me error. How can i resolve this issue ? FROM maven:3.6.3-adoptopenjdk-11 RUN apt-get update -y I checked many posts before writing this and this is what i have tried so far but nothing worked: Replaced "archive.ubuntu.com" with "us.archive.ubuntu.com" in /etc/apt/sources.list Replaced ..

Read more