Category : apple-m1

I have simple docker-compose.yml below, that works in my MacBook Pro 15" (normal Intel Processor) version: "3.0" services: elasticsearch: container_name: es-container image: docker.elastic.co/elasticsearch/elasticsearch:7.11.0 environment: – xpack.security.enabled=false – "discovery.type=single-node" networks: – es-net ports: – 9200:9200 kibana: container_name: kb-container image: docker.elastic.co/kibana/kibana:7.11.0 environment: – ELASTICSEARCH_HOSTS=http://es-container:9200 networks: – es-net depends_on: – elasticsearch ports: – 5601:5601 networks: es-net: driver: bridge ..

Read more

Switched to m1 mac a week ago and I cannot get my application up and running with docker because of the jboss/keycloak image not working as expected. Getting the following message from the container when trying to access localhost:8080 12:08:12,456 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-5) MSC000001: Failed to start service org.wildfly.network.interface.private: org.jboss.msc.service.StartException in service ..

Read more

I’v installed docker by homebrew on Mac with m1 cpu. But it doesn’t run. It tells me that I need to use intel cpu. But on Docker site I see that docker should run. How to fix that? Incompatible CPU detected We are sorry, but your hardware is incompatible with Docker Desktop. This version of ..

Read more

Varnish fails to run the VCC compiler of qemu x86_64 on my Mac M1, with this message: Error: Running VCC-compiler failed, signal 5 VCL compilation failed I use Mac Pro M1, Docker 3.3.0 (62632) Configuration docker-compose: version: ‘3.7’ services: mysql: image: mysql:5.7 volumes: – ./docker/mysql/sql-scripts:/docker-entrypoint-initdb.d/ ports: – 3306:3306 environment: MYSQL_ROOT_PASSWORD: ${MYSQL_ROOT_PASSWORD} MYSQL_USER: ${MYSQL_USER} MYSQL_PASSWORD: ${MYSQL_PASSWORD} ..

Read more

I try to install php-xdebug in docker, but I got this error #5 7.875 ERROR: unsatisfiable constraints: #5 7.875 php5-xdebug-2.5.5-r0: #5 7.875 masked in: cache #5 7.875 satisfies: #5 7.875 world[php5-xdebug><Q1Qep6HHzf56Q7ucrPzV1CAFSr+G8=] #5 7.875 so:libc.musl-x86_64.so.1 (missing): #5 7.875 required by: #5 7.875 php5-xdebug-2.5.5-r0[so:libc.musl-x86_64.so.1] I used alpine:3.7 will Apple M1. How can I solve this problem? Beginning ..

Read more

The code is the hello world app that comes with pycharm for flask apps, very simple build. When deploying to the local test container all is fine, when deploying to Cloud Run it builds a container locally and pushes it to the google repository (error free and seemingly ok) but fails when it tries to ..

Read more

I’m using docker to develop something on macOS Apple Silicon M1. (MacMini) I did follow things. docker pull official ubuntu/focal Create image docker create -it –mount type=bind,source=${HOME}/work/dev1,destination=/root/work/dev1 –name dev1 ubuntu:focal /bin/bash Create container and attach it docker start -ia dev1 After this, I have used this container with coding, running node apps and so on. ..

Read more

this is message what’s wrong? I should wait for the production docker? this is docker config: # build stage FROM node:lts-alpine as build-stage WORKDIR /app COPY package*.json ./ RUN npm install COPY ./ . RUN npm run build # production stage FROM nginx:stable-alpine as production-stage RUN mkdir /app COPY –from=build-stage /app/dist /app COPY nginx.conf /etc/nginx/nginx.conf ..

Read more