Questions tagged amazon-linux-2

Explore the latest questions and answers asked by our top developers.

How to get ‘docker in docker’ running with amazonlinux2?

I need to get docker in docker working with amazonlinux, has anyone done this before? I understand there is a dind image but this has to be amazonlinux2 for a number of reasons (will not detail) I am not looking to get docker running in an EC2 instance, but within docker itself, the Dockerfile beings […]

By user10664542
Published
Categorised as amazon-linux-2, dind, docker, dockerfile Tagged , , ,

Error when running yum on Amazon Linux 2 – "SSL certificate problem: unable to get local issuer certificate"

I have a Docker container based on the latest amazonlinux image running on my work computer and I get this error when I attempt to run yum "anything" (e.g. yum update, yum install ____): failure: repodata/repomd.xml from amzn2-core: [Errno 256] No more mirrors to try. https://cdn.amazonlinux.com/2/core/2.0/x86_64/f915d0987d73328ab3992d03ddbce189bca8804de19d89f09b847dfcaa6bc1af/repodata/repomd.xml?instance_id=URLError&region=unknown: [Errno 14] curl#60 – "SSL certificate problem: unable to […]

By jspinella
Published
Categorised as amazon-linux-2, docker, proxy, yum Tagged , , ,

How to run a hub pulled docker image setting the environment variables

I have a Django project and I’m trying to deploy it on an AWS EC2 instance. I’ve created 2 docker images (application and nginx), tested locally, pushed to hub, but when I pull in my EC2 instance and try to run it, I’m getting environment variable errors like this one: File "/usr/local/lib/python3.9/site-packages/django/conf/__init__.py", line 90, in […]

How to use localectl and timedatectl in amazon linux 2 image?

When I do it in amazon linux 2 container, it returned this issue. bash-4.2# localectl status Failed to create bus connection: No such file or directory bash-4.2# timedatectl Failed to create bus connection: No such file or directory Source: Docker Questions

By Miantian
Published
Categorised as amazon-linux-2, docker, locale Tagged , ,

Which ASP.NET Core base image for Amazon Linux 2 AMI

I want to build a Docker image of my ASP.NET Core application to deploy to an EC2 AMD64 instance using the Amazon Linux 2 AMI. Which Microsoft base image for the runtime should I use? Amazon Linux 2 is an RPM distribution I can see, but I don’t know which tag that translates to on […]

By Peter May
Published
Categorised as amazon-linux-2, asp.net-core, docker Tagged , ,

docker-compose network failed in Amazon Linux 2

I have a EC2 instance with distro amazon linux 2, I have install docker and docker-compose successfully. I have a Dockerfile like this: ## Build Stage FROM python:3.8.8-slim-buster AS build LABEL stage=build ## Install dependencies RUN apt-get update -y && apt-get install -y curl bash wget htop gcc zip sudo Case 1 (Failed): When I […]

By Tho Quach
Published
Categorised as amazon-linux-2, docker Tagged ,

Shutdown container using AmazonLinux docker image

I am unable to shutdown the amazon linux container. shutdown: command not found poweroff: command not found Is the a way to install any package in amazon linux image which helps to bring down the container after my task is accomplished? https://hub.docker.com/_/amazonlinux Also, tried to check in paths like /usr/bin and /sbin but no luck. […]

New versions of docker packages are not available in the amazon-linux-extras

I have a requirement of updating the docker version to 19.03.11 or later on the amazonlinx2 and that package is not listed in the package list. If I execute amazon-linux-extras install docker=19.03.11 it won’t be succeeded and says "Nothing to do" But, if I just execute only amazon-linux-extras install docker it will install the version […]

python3.8 devel package for amazon linux

I’m building a docker image based on amazonlinux:2.0.20210126.0, my software needs to compile and requires Python.h and other dev resources. I’m installing python3.8 like this in my docker file: RUN amazon-linux-extras enable python3.8 RUN yum install -y python3.8 but can’t find any devel packages for python3.8 on amazonlinux repos. Tried looking for python3.8-devel or libpython3.8-dev […]

By M Sh
Published
Categorised as amazon-linux-2, docker, python-3.8 Tagged , ,

How to install nginx version 1.18 in Amazon Linux 2

I am using Amazon Linux with docker and using nginx1.12 but nginx1.12 has end-of-support date of 2019-09-20. So I thought of using nginx1.18. in DockerFile earlier I use RUN amazon-linux-extras install -y nginx1.12 and that was working fine but when I tried use RUN amazon-linux-extras install -y nginx1.18 or RUN amazon-linux-extras install -y nginx1=1.18 it […]

By Puneet Kumar
Published
Categorised as amazon-linux-2, docker, nginx Tagged , ,
1 2

Still Have Questions?


Our dedicated development team is here for you!

We can help you find answers to your question for as low as 5$.

Contact Us
faq