Author : Hasina Njaratin

I have created a full symfony project (composer create-project composer create-project symfony / website-skeleton myproj "^ 4.4.18"). After having configured the environment variables (trusted_host, database_url, etc …). If I run php -S 127.0.0.1:8000 -t public / => Everything works perfectly. I have the symfony welcome page with the debug toolbar On the other hand, if ..

Read more

I have such Dockerfile for my php-container: FROM my-image/debian ARG PHP_VERSION … … RUN set -eux # INSTALL SURY SOURCES && buildDeps=’apt-transport-https lsb-release wget’ && apt-get update && apt-get install -y –no-install-recommends –no-install-suggests $buildDeps && wget -O /etc/apt/trusted.gpg.d/php.gpg https://packages.sury.org/php/apt.gpg && echo "deb https://packages.sury.org/php/ buster main" > /etc/apt/sources.list.d/php.list && update-ca-certificates # INSTALL PHP PACKAGES && apt-get ..

Read more

I have such structure : In my Makefile, I build the dockerfile: sudo docker build –build-arg PHP_VERSION=7.4 -t kaiza/image-php74 – < dockerfile/Dockerfile.php And kaiza/image-php74 is well created locally, if i do docker images, i get: Then, in my docker-compose.php74.yml : version: ‘2.4’ services: php7.4: image: "kaiza/image-php74" container_name: "kz-php74" hostname: "kz-php74" user: 1000:1000 … But, when ..

Read more

I have such structure : In my Makefile, I build the dockerfile: sudo docker build –build-arg PHP_VERSION=7.4 -t kaiza/image-php74 – < dockerfile/Dockerfile.php And kaiza/image-php74 is well created locally, if i do docker images, i get: Then, in my docker-compose.php74.yml : version: ‘2.4’ services: php7.4: image: "kaiza/image-php74" container_name: "kz-php74" hostname: "kz-php74" user: 1000:1000 … But, when ..

Read more