yum Install Docker on Centos | Reqires container-selinux libseccomp slirp4netns fuse-overlayfs error

Published

we are trying to install docker on our Centos 7.5 according to https://phoenixnap.com/kb/how-to-install-docker-centos-7 and some other similar guides and failing with following error, can someone advise how to overcome it or provide alternative installation steps from his experience?

[[email protected]******1 ~]# yum install -y docker-ce
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile

  • centos-sclo-rh: centos.spd.co.il
    Resolving Dependencies
    –> Running transaction check
    —> Package docker-ce.x86_64 3:20.10.8-3.el7 will be installed
    –> Processing Dependency: container-selinux >= 2:2.74 for package: 3:docker-ce-20.10.8-3.el7.x86_64
    –> Processing Dependency: containerd.io >= 1.4.1 for package: 3:docker-ce-20.10.8-3.el7.x86_64
    –> Processing Dependency: libseccomp >= 2.3 for package: 3:docker-ce-20.10.8-3.el7.x86_64
    –> Processing Dependency: docker-ce-cli for package: 3:docker-ce-20.10.8-3.el7.x86_64
    –> Processing Dependency: docker-ce-rootless-extras for package: 3:docker-ce-20.10.8-3.el7.x86_64
    –> Running transaction check
    —> Package containerd.io.x86_64 0:1.4.9-3.1.el7 will be installed
    –> Processing Dependency: container-selinux >= 2:2.74 for package: containerd.io-1.4.9-3.1.el7.x86_64
    –> Processing Dependency: libseccomp for package: containerd.io-1.4.9-3.1.el7.x86_64
    —> Package docker-ce.x86_64 3:20.10.8-3.el7 will be installed
    –> Processing Dependency: container-selinux >= 2:2.74 for package: 3:docker-ce-20.10.8-3.el7.x86_64
    –> Processing Dependency: libseccomp >= 2.3 for package: 3:docker-ce-20.10.8-3.el7.x86_64
    —> Package docker-ce-cli.x86_64 1:20.10.8-3.el7 will be installed
    –> Processing Dependency: docker-scan-plugin(x86-64) for package: 1:docker-ce-cli-20.10.8-3.el7.x86_64
    —> Package docker-ce-rootless-extras.x86_64 0:20.10.8-3.el7 will be installed
    –> Processing Dependency: fuse-overlayfs >= 0.7 for package: docker-ce-rootless-extras-20.10.8-3.el7.x86_64
    –> Processing Dependency: slirp4netns >= 0.4 for package: docker-ce-rootless-extras-20.10.8-3.el7.x86_64
    –> Running transaction check
    —> Package containerd.io.x86_64 0:1.4.9-3.1.el7 will be installed
    –> Processing Dependency: container-selinux >= 2:2.74 for package: containerd.io-1.4.9-3.1.el7.x86_64
    –> Processing Dependency: libseccomp for package: containerd.io-1.4.9-3.1.el7.x86_64
    —> Package docker-ce.x86_64 3:20.10.8-3.el7 will be installed
    –> Processing Dependency: container-selinux >= 2:2.74 for package: 3:docker-ce-20.10.8-3.el7.x86_64
    –> Processing Dependency: libseccomp >= 2.3 for package: 3:docker-ce-20.10.8-3.el7.x86_64
    —> Package docker-ce-rootless-extras.x86_64 0:20.10.8-3.el7 will be installed
    –> Processing Dependency: fuse-overlayfs >= 0.7 for package: docker-ce-rootless-extras-20.10.8-3.el7.x86_64
    –> Processing Dependency: slirp4netns >= 0.4 for package: docker-ce-rootless-extras-20.10.8-3.el7.x86_64
    —> Package docker-scan-plugin.x86_64 0:0.8.0-3.el7 will be installed
    –> Finished Dependency Resolution
    Error: Package: 3:docker-ce-20.10.8-3.el7.x86_64 (docker-ce-stable)
    Requires: container-selinux >= 2:2.74

    Error: Package: 3:docker-ce-20.10.8-3.el7.x86_64 (docker-ce-stable)
    Requires: libseccomp >= 2.3

    Error: Package: containerd.io-1.4.9-3.1.el7.x86_64 (docker-ce-stable)
    Requires: container-selinux >= 2:2.74

    Error: Package: docker-ce-rootless-extras-20.10.8-3.el7.x86_64 (docker-ce-stable)
    Requires: slirp4netns >= 0.4

    Error: Package: docker-ce-rootless-extras-20.10.8-3.el7.x86_64 (docker-ce-stable)
    Requires: fuse-overlayfs >= 0.7

    Error: Package: containerd.io-1.4.9-3.1.el7.x86_64 (docker-ce-stable)
    Requires: libseccomp

    You could try using –skip-broken to work around the problem
    You could try running: rpm -Va –nofiles –nodigest

Thanks,
Noam

Source: Docker Questions

Published
Categorised as centos, centos7, docker, docker-compose, yum Tagged , , , ,

Answers

Leave a Reply

Still Have Questions?


Our dedicated development team is here for you!

We can help you find answers to your question for as low as 5$.

Contact Us
faq