How to find the right libnvinfer version for Cuda

  cuda, docker, dockerfile, python, tensorflow

I am building a Docker image, for deep learning:

cuda:11.2.0-cudnn8-devel-ubuntu20.04
PYTHON_VERSION=3.7.9

For this task I need 3 dependencies to install, but I can’t find the right version. The error I get, when building the Docker image:

E: Version ‘8.1.1.33-1+cuda11.2’ for ‘libnvinfer8’ was not found E:
Version ‘8.1.1.33-1+cuda11.2’ for ‘libnvinfer-dev’ was not found E:
Version ‘8.1.1.33-1+cuda11.2’ for ‘libnvinfer-plugin8’ was not found

I was experimenting with other versions as well, but I had no success, so the question is: where/how can I find the right versions which works with cuda 11.2 and ubuntu 20.04.

Source: Docker Questions

LEAVE A COMMENT