Unable to pull and build docker images after macOS 11.3.1 and latest Docker Community edition

  build, docker, macos

So I’m trying to build my local golang image and/or pull images and I’m receiving an error I haven’t seen before (on macOS Big Sur 11.3.1). Also, I don’t know if this is related to the recent update to macOS messing things up or something different. I do this from my home LAN and I’ve never had issues with this before. Sorry for side-scrollable text.

This behaviour is repeated for all kinds of docker pull/build and things I’ve tried so far are:

  • restart docker engine
  • restart mac
  • tried setting proxy settings manually for http/https (HTTP Proxy: http.docker.internal:3128
    HTTPS Proxy: https.docker.internal:3128) as per other thread here on stack.
❯ docker build -t oscaralmgren/banking-api .
[+] Building 8.9s (3/3) FINISHED                                                                                                                          
 => [internal] load build definition from Dockerfile                                                                                                 0.6s
 => => transferring dockerfile: 214B                                                                                                                 0.0s
 => [internal] load .dockerignore                                                                                                                    0.4s
 => => transferring context: 2B                                                                                                                      0.0s
 => ERROR [internal] load metadata for docker.io/library/golang:latest                                                                               8.1s
------
 > [internal] load metadata for docker.io/library/golang:latest:
------
failed to solve with frontend dockerfile.v0: failed to create LLB definition: failed to do request: Head https://registry-1.docker.io/v2/library/golang/manifests/latest: proxyconnect tcp: dial tcp 192.168.65.1:3128: connect: network is unreachable 

❯ docker pull mongo
Using default tag: latest
Error response from daemon: Get https://registry-1.docker.io/v2/: proxyconnect tcp: dial tcp 192.168.65.1:3128: connect: network is unreachable

❯ docker version
Client:
 Cloud integration: 1.0.14
 Version:           20.10.6
 API version:       1.41
 Go version:        go1.16.3
 Git commit:        370c289
 Built:             Fri Apr  9 22:46:57 2021
 OS/Arch:           darwin/amd64
 Context:           default
 Experimental:      true

Server: Docker Engine - Community
 Engine:
  Version:          20.10.6
  API version:      1.41 (minimum version 1.12)
  Go version:       go1.13.15
  Git commit:       8728dd2
  Built:            Fri Apr  9 22:44:56 2021
  OS/Arch:          linux/amd64
  Experimental:     false
 containerd:
  Version:          1.4.4
  GitCommit:        05f951a3781f4f2c1911b05e61c160e9c30eaa8e
 runc:
  Version:          1.0.0-rc93
  GitCommit:        12644e614e25b05da6fd08a38ffa0cfe1903fdec
 docker-init:
  Version:          0.19.0
  GitCommit:        de40ad0

Source: Docker Questions

LEAVE A COMMENT