Docker version is different from what was intended from the command

Published
[[email protected] yum.repos.d]# yum install docker-ce-20.10.2*
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: la.mirrors.clouvider.net
 * extras: mirrors.ocf.berkeley.edu
 * updates: sjc.edge.kernel.org
Resolving Dependencies
--> Running transaction check
---> Package docker-ce.x86_64 3:20.10.2-3.el7 will be installed
--> Processing Dependency: container-selinux >= 2:2.74 for package: 3:docker-ce-20.10.2-3.el7.x86_64
--> Processing Dependency: containerd.io >= 1.4.1 for package: 3:docker-ce-20.10.2-3.el7.x86_64
--> Processing Dependency: docker-ce-cli for package: 3:docker-ce-20.10.2-3.el7.x86_64
--> Processing Dependency: docker-ce-rootless-extras for package: 3:docker-ce-20.10.2-3.el7.x86_64
--> Running transaction check
---> Package container-selinux.noarch 2:2.119.2-1.911c772.el7_8 will be installed
---> Package containerd.io.x86_64 0:1.4.4-3.1.el7 will be installed
---> Package docker-ce-cli.x86_64 1:20.10.6-3.el7 will be installed
--> Processing Dependency: docker-scan-plugin(x86-64) for package: 1:docker-ce-cli-20.10.6-3.el7.x86_64
---> Package docker-ce-rootless-extras.x86_64 0:20.10.6-3.el7 will be installed
--> Processing Dependency: fuse-overlayfs >= 0.7 for package: docker-ce-rootless-extras-20.10.6-3.el7.x86_64
--> Processing Dependency: slirp4netns >= 0.4 for package: docker-ce-rootless-extras-20.10.6-3.el7.x86_64
--> Running transaction check
---> Package docker-scan-plugin.x86_64 0:0.7.0-3.el7 will be installed
---> Package fuse-overlayfs.x86_64 0:0.7.2-6.el7_8 will be installed
--> Processing Dependency: libfuse3.so.3(FUSE_3.2)(64bit) for package: fuse-overlayfs-0.7.2-6.el7_8.x86_64
--> Processing Dependency: libfuse3.so.3(FUSE_3.0)(64bit) for package: fuse-overlayfs-0.7.2-6.el7_8.x86_64
--> Processing Dependency: libfuse3.so.3()(64bit) for package: fuse-overlayfs-0.7.2-6.el7_8.x86_64
---> Package slirp4netns.x86_64 0:0.4.3-4.el7_8 will be installed
--> Running transaction check
---> Package fuse3-libs.x86_64 0:3.6.1-4.el7 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

======================================================================================
 Package                   Arch   Version                      Repository        Size
======================================================================================
Installing:
 docker-ce                 x86_64 3:20.10.2-3.el7              docker-ce-stable  27 M
Installing for dependencies:
 container-selinux         noarch 2:2.119.2-1.911c772.el7_8    extras            40 k
 containerd.io             x86_64 1.4.4-3.1.el7                docker-ce-stable  33 M
 docker-ce-cli             x86_64 1:20.10.6-3.el7              docker-ce-stable  33 M
 docker-ce-rootless-extras x86_64 20.10.6-3.el7                docker-ce-stable 9.2 M
 docker-scan-plugin        x86_64 0.7.0-3.el7                  docker-ce-stable 4.2 M
 fuse-overlayfs            x86_64 0.7.2-6.el7_8                extras            54 k
 fuse3-libs                x86_64 3.6.1-4.el7                  extras            82 k
 slirp4netns               x86_64 0.4.3-4.el7_8                extras            81 k

Transaction Summary
======================================================================================
Install  1 Package (+8 Dependent packages)

Total download size: 107 M
Installed size: 438 M
Is this ok [y/d/N]: y
Downloading packages:
(1/9): container-selinux-2.119.2-1.911c772.el7_8.noarch.rpm    |  40 kB  00:00:00
warning: /var/cache/yum/x86_64/7/docker-ce-stable/packages/docker-ce-20.10.2-3.el7.x86_64.rpm: Header V4 RSA/SHA512 Signature, key ID 621e9f35: NOKEY
Public key for docker-ce-20.10.2-3.el7.x86_64.rpm is not installed
(2/9): docker-ce-20.10.2-3.el7.x86_64.rpm                      |  27 MB  00:00:00
(3/9): containerd.io-1.4.4-3.1.el7.x86_64.rpm                  |  33 MB  00:00:00
(4/9): docker-ce-cli-20.10.6-3.el7.x86_64.rpm                  |  33 MB  00:00:00
(5/9): docker-scan-plugin-0.7.0-3.el7.x86_64.rpm               | 4.2 MB  00:00:00
(6/9): docker-ce-rootless-extras-20.10.6-3.el7.x86_64.rpm      | 9.2 MB  00:00:00
(7/9): fuse-overlayfs-0.7.2-6.el7_8.x86_64.rpm                 |  54 kB  00:00:00
(8/9): slirp4netns-0.4.3-4.el7_8.x86_64.rpm                    |  81 kB  00:00:00
(9/9): fuse3-libs-3.6.1-4.el7.x86_64.rpm                       |  82 kB  00:00:00
--------------------------------------------------------------------------------------
Total                                                     49 MB/s | 107 MB  00:02
Retrieving key from https://download.docker.com/linux/centos/gpg
Importing GPG key 0x621E9F35:
 Userid     : "Docker Release (CE rpm) <[email protected]>"
 Fingerprint: 060a 61c5 1b55 8a7f 742b 77aa c52f eb6b 621e 9f35
 From       : https://download.docker.com/linux/centos/gpg
Is this ok [y/N]: y
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  Installing : 2:container-selinux-2.119.2-1.911c772.el7_8.noarch                 1/9
  Installing : containerd.io-1.4.4-3.1.el7.x86_64                                 2/9
  Installing : 1:docker-ce-cli-20.10.6-3.el7.x86_64                               3/9
  Installing : docker-scan-plugin-0.7.0-3.el7.x86_64                              4/9
  Installing : slirp4netns-0.4.3-4.el7_8.x86_64                                   5/9
  Installing : fuse3-libs-3.6.1-4.el7.x86_64                                      6/9
  Installing : fuse-overlayfs-0.7.2-6.el7_8.x86_64                                7/9
  Installing : 3:docker-ce-20.10.2-3.el7.x86_64                                   8/9
  Installing : docker-ce-rootless-extras-20.10.6-3.el7.x86_64                     9/9
  Verifying  : fuse3-libs-3.6.1-4.el7.x86_64                                      1/9
  Verifying  : 3:docker-ce-20.10.2-3.el7.x86_64                                   2/9
  Verifying  : docker-ce-rootless-extras-20.10.6-3.el7.x86_64                     3/9
  Verifying  : fuse-overlayfs-0.7.2-6.el7_8.x86_64                                4/9
  Verifying  : docker-scan-plugin-0.7.0-3.el7.x86_64                              5/9
  Verifying  : slirp4netns-0.4.3-4.el7_8.x86_64                                   6/9
  Verifying  : 2:container-selinux-2.119.2-1.911c772.el7_8.noarch                 7/9
  Verifying  : 1:docker-ce-cli-20.10.6-3.el7.x86_64                               8/9
  Verifying  : containerd.io-1.4.4-3.1.el7.x86_64                                 9/9

Installed:
  docker-ce.x86_64 3:20.10.2-3.el7

Dependency Installed:
  container-selinux.noarch 2:2.119.2-1.911c772.el7_8
  containerd.io.x86_64 0:1.4.4-3.1.el7
  docker-ce-cli.x86_64 1:20.10.6-3.el7
  docker-ce-rootless-extras.x86_64 0:20.10.6-3.el7
  docker-scan-plugin.x86_64 0:0.7.0-3.el7
  fuse-overlayfs.x86_64 0:0.7.2-6.el7_8
  fuse3-libs.x86_64 0:3.6.1-4.el7
  slirp4netns.x86_64 0:0.4.3-4.el7_8

Complete!
[[email protected] yum.repos.d]# docker --version
Docker version 20.10.6, build 370c289
[[email protected] yum.repos.d]#

I tried installing docker 20.10.2 as I need it to match one of my pre-installed docker node. I confirmed before going ahead and hitting y; yum too confirmed that docker 20.10.2 will be installed; however, the installed version is 20.10.6. Do I need to make changes in the repos? Is it something based on stable versions of a product that are available at a given point in time?

Source: Docker Questions

Published
Categorised as centos, docker, yum Tagged , ,

Answers

Leave a Reply

Still Have Questions?


Our dedicated development team is here for you!

We can help you find answers to your question for as low as 5$.

Contact Us
faq