docker shared volume not propagating

  devops, docker, docker-compose, docker-volume

my shared volume is not propagating and I’m not sure why. My docker version is

Client: Docker Engine - Community
 Cloud integration: 1.0.9
 Version:           20.10.5
 API version:       1.41
 Go version:        go1.13.15
 Git commit:        55c4c88
 Built:             Tue Mar  2 20:13:00 2021
 OS/Arch:           darwin/amd64
 Context:           default
 Experimental:      true

Server: Docker Engine - Community
 Engine:
  Version:          20.10.5
  API version:      1.41 (minimum version 1.12)
  Go version:       go1.13.15
  Git commit:       363e9a8
  Built:            Tue Mar  2 20:15:47 2021
  OS/Arch:          linux/amd64
  Experimental:     false
 containerd:
  Version:          1.4.3
  GitCommit:        269548fa27e0089a8b8278fc4fc781d7f65a939b
 runc:
  Version:          1.0.0-rc92
  GitCommit:        ff819c7e9184c13b7c2607fe6c30ae19403a7aff
 docker-init:
  Version:          0.19.0
  GitCommit:        de40ad0

and the relevant portion of my docker-compose file is

version: '3'
services:
  mycontainer:
    expose:
      - 8000
    entrypoint: /bin/sh -c entrypoint.sh
    volumes: 
      - app-files:/srv/
volumes:
  app-files:
    driver: local
    driver_opts:
      type: nfs
      device: ${PWD}
      o: bind

When I make changes to files in my present work directory, they never seem to show up inside of my containers. Does anybody know why this is happening?

Source: Docker Questions

LEAVE A COMMENT