Unsupported operating system with Docker on windows 10 with wsl2

  docker, laravel-sail

i installed docker and downloaded an ubuntu distro to run with laravel sail,planing to use swoole php,and made it default,also made wsl version to 2
wsl list

with docker-compose.yml ready from laravel sail
docker-compose.yml

but every time i try to run the sail up cmd,it gives me this error " Unsupported operating system [MINGW64_NT-10.0]. Laravel Sail supports macOS, Linux, and Windows (WSL2)."

sail up command

any ideas how to fix this ?

Source: Docker Questions

LEAVE A COMMENT