build docker image failed at install package based on requirements.txt

Use ‘docker build -t test-scripts:1.0 .’ to build docker image, but failed at issue as follows. Then I removed related package name from requirements.txt, but it will hit another package issue. How can i fix this issue?

And in this requirements.txt, i need to use pip3 to install package, but the error info shows "You are using pip version 10.0.1, however version 20.2.4 is available." pip version is already 20.2.4, it still shows using 10.0.1. I don’t know why.

My Dockerfile content are:

FROM python:3.6.5   

WORKDIR /home/scripts

COPY requirements.txt .

RUN pip3 install -r requirements.txt

COPY . .

CMD ["python3", "/home/scripts/run_cmd.sh"]

….

Collecting en-core-web-sm==2.3.1 (from -r requirements.txt (line 13))
  Could not find a version that satisfies the requirement en-core-web-sm==2.3.1 (from -r requirements.txt (line 13)) (from versions: )
No matching distribution found for en-core-web-sm==2.3.1 (from -r requirements.txt (line 13))
You are using pip version 10.0.1, however version 20.2.4 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.

Source: Docker Questions