raise ValueError("Unsupported Lambda runtime {}".format(runtime))

Has anyone had this error recently?

File “C:Program
FilesAmazonAWSSAMCLIruntimelibsite-packagessamclilocaldockerlambda_container.py”,
line 65, in init
raise ValueError(“Unsupported Lambda runtime {}”.format(runtime)) ValueError: Unsupported Lambda runtime nodejs12.x

If so, how did you solve it?

So far I have tried uninstalling aws-sam-cli and reinstalling. Then I tried the same with Docker.

I have checked that the runtime for is set to nodejs12.x for each lambda function.

It gets thrown when I try to debug any lambda function locally in vscode. Up until about 2 weeks ago I was able to debug. All I find when I Google the problem are various references to the fact that “On 18th November 2019, AWS published they are now supporting Node.js 12.x runtime in AWS Lambda”.

Thanks in advance to anyone who might be able to help me.

Source: StackOverflow