Whatsup Developer Setup: Single Instance doesn’t work

I just followed the guide for setup single instance of the WhatsApp Business API Client on my development laptop.

Here what I have done.

export WA_API_VERSION=2.23.4 
mkdir ~/biz; cd ~/biz;
vim docker-compose.yml
vim  db.env

Here is my docker-compose.yml.

version: ‘3’

volumes:
  whatsappMedia:
    driver: local
  mysqlData:
    driver: local

services:
  db:
    image: mysql:5.7.22
    restart: always
    environment:
      MYSQL_ROOT_PASSWORD: testpass
      MYSQL_USER: testuser
      MYSQL_PASSWORD: testpass
    expose:
        - "33060"
    ports:
        - "33060:3306"
    volumes:
     - mysqlData:/var/lib/mysql
    network_mode: bridge
  wacore:
    image: docker.whatsapp.biz/coreapp:v${WA_API_VERSION:?Run docker-compose with env var WA_API_VERSION (ex. WA_API_VERSION=2.25.1 docker-compose <command> <options>)}
    command: ["/opt/whatsapp/bin/wait_on_mysql.sh", "/opt/whatsapp/bin/launch_within_docker.sh"]
    volumes:
     - whatsappMedia:/usr/local/wamedia
    env_file:
      - db.env
    environment:
      # This is the version of the docker templates being used to run WhatsApp Business API
      WA_RUNNING_ENV_VERSION: v2.2.3
      ORCHESTRATION: DOCKER-COMPOSE
    depends_on:
      - "db"
    network_mode: bridge
    links:
      - db
  waweb:
    image: docker.whatsapp.biz/web:v${WA_API_VERSION:?Run docker-compose with env var WA_API_VERSION (ex. WA_API_VERSION=2.25.1 docker-compose <command> <options>)}
    command: ["/opt/whatsapp/bin/wait_on_mysql.sh", "/opt/whatsapp/bin/launch_within_docker.sh"]
    ports:
     - "9090:443"
    volumes:
     - whatsappMedia:/usr/local/wamedia
    env_file:
      - db.env
    environment:
      WACORE_HOSTNAME: wacore
      # This is the version of the docker templates being used to run WhatsApp Business API
      WA_RUNNING_ENV_VERSION: v2.2.3
      ORCHESTRATION: DOCKER-COMPOSE
    depends_on:
      - "db"
      - "wacore"
    links:
      - db
      - wacore
    network_mode: bridge

Here is my db.env

WA_DB_ENGINE=MYSQL
WA_DB_HOSTNAME=db
WA_DB_PORT=3306
WA_DB_USERNAME=root
WA_DB_PASSWORD=testpass

My problem is following error:

ERROR: error pulling image configuration: error parsing HTTP 403
response body: invalid character ‘F’ looking for beginning of value:
“Forbidden!”

docker-compose up -d
Pulling wacore (docker.whatsapp.biz/coreapp:v2.25.1)...
v2.25.1: Pulling from coreapp
f7277927d38a: Pulling fs layer
8d3eac894db4: Pulling fs layer
edf72af6d627: Pulling fs layer
3e4f86211d23: Waiting
5d2d43cc5628: Waiting
642de7dad286: Waiting
190c5494fb3d: Waiting
6033f41a5967: Waiting
40c5d4c537a1: Waiting
ee5cf602d6ab: Waiting
675b149f621c: Waiting
ebc7ee87473d: Waiting
6312534fd246: Waiting
37d09b4c9058: Waiting
ERROR: error pulling image configuration: error parsing HTTP 403 response body: invalid character 'F' looking for beginning of value: "Forbidden!"

Anyone can help?

Source: StackOverflow