Load .Rda file in R giving error Magic Number

I am trying to load .Rda file in R woth load() function in a docker container but it’s giving me the error “file ‘decrypted_model.Rdata’ has magic number ‘RDX3’
Use of save versions prior to 2 is deprecated”

R_BASE_VERSION is 3.6.

caret package version is 6.0-84

I am using image of ubuntu:16.04

I am using load function for this:

load('decrypted_model.Rda')

Is there any workaround for this or any way to solve this?

Source: StackOverflow