docker-compose: check the compatibility

I have the below docker system on my linux host:

#  docker --version
Docker version 18.06.1-ce, build e68fc7a215


#  docker-compose --version
docker-compose version 1.20.1, build unknown

As per the compatability matrix:
https://docs.docker.com/compose/compose-file/compose-versioning/#compatibility-matrix

Compose file format        Docker Engine release
3.7                        18.06.0+
3.6                        18.02.0+

As per the release notes of docker-compose VERSION 3.6 can be used from release version 1.20.1
https://docs.docker.com/release-notes/docker-compose/

1.20.0 (2018-03-20)
New features
COMPOSE FILE VERSION 3.6
Introduced version 3.6 of the docker-compose.yml specification. This version must be used with Docker Engine 18.02.0 or above.

Added support for the tmpfs.size property in volume mappings

Since my docker version is 18.06.0+ will Version 3.6 (for release 1.20.1) work since for 18.06.0+ compose version 3.7 is compatible

Source: StackOverflow